Uploaded image for project: 'CUBRID APIs'
  1. CUBRID APIs
  2. APIS-662

[PHP] CCI version number is 9.2.0 in PHP driver 8.4.4

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: PHP 8.4.4.0001
    • Fix Version/s: PHP 8.4.4.0002
    • Component/s: PHP Driver
    • Labels:
    • Environment:
      • OS: Linux 64bit
      • CUBRID: 8.4.4.2001
      • PHP: 5.5.0
      • Driver: cubrid-php 8.4.4.0002 (20130903)

      Description

      • Brief: I have noticed that the CCI version number used in PHP Driver 8.4.4 is 9.2.0, user may not understand why we use CCI 9.2.0 in the php driver 8.4.4.

      I suggest change the CCI version number 9.2.0 to 8.4.4, in order to ensure the consistency between PHP Driver and its packaged CCI driver

      $conn_url = "CUBRID:xx.xx.xx.xx:33000:demodb:dba::";
      $conn = cubrid_connect_with_url($conn_url);
      
      $cubrid_library_version=cubrid_get_client_info();
      var_dump($cubrid_library_version);
      

      Actual Result: 9.2.0
      Expected: 8.4.4

        Activity

        Hide
        cn15800 谢韦华[Bert] added a comment -

        We use cci_get_version to get cci version number, and i have checked the source code and test the driver on my environment, the version number is correct.

        Show
        cn15800 谢韦华[Bert] added a comment - We use cci_get_version to get cci version number, and i have checked the source code and test the driver on my environment, the version number is correct.
        Hide
        cn15800 谢韦华[Bert] added a comment -

        Linux

        The version of cci is 8.4.4

        Windows

        The driver will link the cci lib which user installed, so the version is not fixed

        Show
        cn15800 谢韦华[Bert] added a comment - Linux The version of cci is 8.4.4 Windows The driver will link the cci lib which user installed, so the version is not fixed
        Hide
        ryin005 Ray Yin added a comment -
        • Test OS: Linux 64, Win32, Win64
        • PHP: 5.5.0, 5.4.3, 5.3.13
        • Driver: cubrid-php 8.4.4.0002 (2013-11-22)

        Test Result: Pass

        Close the issue

        Show
        ryin005 Ray Yin added a comment - Test OS: Linux 64, Win32, Win64 PHP: 5.5.0, 5.4.3, 5.3.13 Driver: cubrid-php 8.4.4.0002 (2013-11-22) Test Result: Pass Close the issue

          People

          • Assignee:
            cn15800 谢韦华[Bert]
            Reporter:
            ryin005 Ray Yin
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: