Uploaded image for project: 'CUBRID APIs'
  1. CUBRID APIs
  2. APIS-641

[ODBC][8.4.4] OdbcCommand.ExecuteNonQuery() always throws an OdbcException on Win64

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a Bug
    • Affects Version/s: ODBC-8.4.4
    • Fix Version/s: None
    • Component/s: ODBC
    • Labels:
    • Environment:
      • OS: WinXP 64bit
      • CUBRID: 8.4.4.0227
      • Driver: cubrid-odbc 8.4.4 (20130821)
      • Framework: .NET

      Description

      • Brief: OdbcCommand.ExecuteNonQuery() always throws an OdbcException on Windows 64bit
      • Test Code {code}
        string strConn = @"Driver={CUBRID Driver};db_name=test_odbc;uid=dba;pwd=;server=10.34.64.57;port=33069;fetch_size=100;charset=UTF-8;";
        OdbcConnection connCubrid = new OdbcConnection(strConn);
        connCubrid.Open();

        OdbcCommand command = new OdbcCommand();
        command.Connection = connCubrid;
        string strCreateTable = "CREATE TABLE test_tbl (id int)";
        command.CommandText = strCreateTable;
        command.ExecuteNonQuery();

        connCubrid.Close();{code}

      Result:

      System.Data.Odbc.OdbcException : ERROR [HY000] [CUBRID][ODBC CUBRID Driver][-10022]No More Result
      

        Activity

        ryin005 Ray Yin added a comment -

        This issue is caused by the CCI dependency, we have to install CUBRID 8.4.4 CCI to test the problem, other CCI versions will cause the failure.

        It's not a driver's bug

        Close the issue


          People

          • Assignee:
            cn15800 谢韦华[Bert]
            Reporter:
            ryin005 Ray Yin
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: