Uploaded image for project: 'CUBRID APIs'
  1. CUBRID APIs
  2. APIS-608

[PDO] The newInstance() returns a fatal error for the reflection class "pdorow" on PHP5.5

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: PHP Driver
    • Labels:
    • Environment:

      OS: Linux 64bit, Win 7 32bit
      Cubrid: 9.1.0.0212
      PHP: 5.5.0
      PDO Driver: 9.1.0.0004 (2013-0717)

      Description

      • Brief: The newInstance() returns a fatal error for the reflection class "pdorow" on PHP5.5
      • Test Code {code}
        <?php
        $instance = new reflectionclass('pdorow');
        var_dump($instance);
        $x = $instance->newInstance();
        var_dump($x);

        ?>{code}

      Expected Result:

      object(ReflectionClass)#1 (1) { ["name"]=> string(6) "PDORow" } object(PDORow)#2 (0) { } 
      

      Actual Result

      object(ReflectionClass)#1 (1) { ["name"]=> string(6) "PDORow" }
      Fatal error: PDORow::__construct(): You should not create a PDOStatement manually in /home/php/public_html/php5_test/pdo_036.php on line 5
      

        Activity

        cn15800 谢韦华[Bert] added a comment -

        This function is implemented by php, not driver.

        ryin005 Ray Yin added a comment -

        The problem is caused by PHP 5.5 but not driver itself.

        So in the current PHP5.5 version, we can not build a newInstance for the reflection class "pdorow"

        Close the issue


          People

          • Assignee:
            cn15800 谢韦华[Bert]
            Reporter:
            ryin005 Ray Yin
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: