Uploaded image for project: 'CUBRID APIs'
  1. CUBRID APIs
  2. APIS-604

Investigate the cause of ECONNRESET when incorrect port is specified

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Not a Bug
    • Affects Version/s: node-cubrid 2.0.2
    • Fix Version/s: node-cubrid 2.1.0
    • Component/s: Node.js
    • Labels:

      Description

      When running the following code from test_BadPort.js test, read ECONNRESET error is thrown. This occurs exclusively when the host is located in a VM (VMware) under Windows 7, and the code is trying to connect to Windows 7 which routes the packets to the VM.

      Check if this behavior is expected or not.

      {code}
      exports['test_BadPort'] = function (test) {
      var CUBRID = require('../'),
      config = require('./testSetup/test_Setup').config,
      client = CUBRID.createCUBRIDConnection(config.host, 80, config.user, config.password, config.database),
      Helpers = CUBRID.Helpers;

      test.expect(1);

      Helpers.logInfo(module.filename.toString() + ' started...');

      client.connect(function (err) {
      if (err) { test.ok(['connect ECONNREFUSED', 'connect ETIMEDOUT', 'read ECONNRESET'].indexOf(err.message) > -1); Helpers.logInfo('Test passed.'); test.done(); } else { throw 'We should not get here!'; }
      });
      };{code}

        Activity

        kadishmal Esen Sagynov added a comment -

        This seems to be not a bug of any sort but a real scenario error message thrown when the remote server sends FIN response before closing the connection. So, this ECONNRESET error has to be expected on connect.


          People

          • Assignee:
            kadishmal Esen Sagynov
            Reporter:
            kadishmal Esen Sagynov
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 5 hours, 55 minutes
              5h 55m