Uploaded image for project: 'CUBRID APIs'
  1. CUBRID APIs
  2. APIS-578

Release 3.0 - Add support for Sequelize

    Details

    • Type: New Feature
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: node-cubrid 3.0.0
    • Fix Version/s: node-cubrid 3.0.0
    • Component/s: Node.js
    • Labels:

      Description

      The Sequelize library provides easy access to a database by mapping database entries to objects and vice versa (the concept is similar to Hibernate). To put it in a nutshell, it's an ORM (Object-Relational-Mapper).

      Sequelize already supports:

      • MySQL
      • PostgreSQL
      • SQLite,
        …and there is no reason it should not support CUBRID as well:
        “With the release of Sequelize v1.6.0, the library got independent from specific dialects. That mean, that you'll have to add the respective dialect library yourself. Another option is the use of the sequelize packages that ship the dialect libraries as well.”

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            ovidiu.guta Ovidiu Guta
            Reporter:
            ovidiu.guta Ovidiu Guta
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated: