Uploaded image for project: 'CUBRID APIs'
  1. CUBRID APIs
  2. APIS-399

[Perl] DBI dependence when building the Cubrid perl driver.

    Details

      Description

      We need DBI 1.61 or higher version in Cubrid Perl driver.

      If the DBI prerequisite isn't meet, there is a warn in "perl Makefile.PL" like the below:

      Warning: prerequisite DBI 1.61 not found. We have 1.52
      

      We should change the prerequisite as a mandatory. If the DBI prerequisite isn't meet, the error will be prompted and the build will exit.

        Activity

        Hide
        jinhu 李金虎 added a comment - - edited

        Add the DBI version check in the Makefile.PL.

        Revision: 1136 fixed in RB-8.4.3
        Revision: 1137 fixed in RB-8.4.1
        Revision: 1138 fixed in RB-8.4.4
        Revision: 1139 fixed in RB-9.0.0
        Revision: 1140 fixed in trunk

        Show
        jinhu 李金虎 added a comment - - edited Add the DBI version check in the Makefile.PL. Revision: 1136 fixed in RB-8.4.3 Revision: 1137 fixed in RB-8.4.1 Revision: 1138 fixed in RB-8.4.4 Revision: 1139 fixed in RB-9.0.0 Revision: 1140 fixed in trunk
        Hide
        cn14130 欧明宝[Bom Owen] added a comment - - edited

        I tested all the versions changed, the log is :

        [api@NC-PL-QA030 RB-9.1.0]$ perl Makefile.PL
        Using DBI 1.52 (for perl 5.008008 on x86_64-linux-thread-multi) installed in /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/DBI/
        DBI version 1.61 required--this is only version 1.52 at /usr/lib/perl5/5.8.8/Exporter/Heavy.pm line 237.
        

        And build has exited

        Show
        cn14130 欧明宝[Bom Owen] added a comment - - edited I tested all the versions changed, the log is : [api@NC-PL-QA030 RB-9.1.0]$ perl Makefile.PL Using DBI 1.52 (for perl 5.008008 on x86_64-linux-thread-multi) installed in /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/DBI/ DBI version 1.61 required--this is only version 1.52 at /usr/lib/perl5/5.8.8/Exporter/Heavy.pm line 237. And build has exited
        Hide
        jinhu 李金虎 added a comment -

        Add the below prompt to make it clearer to user:

        Please install DBI version 1.61 or higher. Exit.
        

        RB-9.1.0, revision: 1564
        RB-8.4.1, revision: 1565
        RB-8.4.3, revision: 1566
        RB-8.4.4, revision: 1567
        trunk, revision: 1568

        Show
        jinhu 李金虎 added a comment - Add the below prompt to make it clearer to user: Please install DBI version 1.61 or higher. Exit. RB-9.1.0, revision: 1564 RB-8.4.1, revision: 1565 RB-8.4.3, revision: 1566 RB-8.4.4, revision: 1567 trunk, revision: 1568

          People

          • Assignee:
            jinhu 李金虎
            Reporter:
            jinhu 李金虎
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: